
 

The EtherCAT-based embedded motion controller optimized for industrial robots. 
 

DTP10-L 
Software 
User’s Manual 

 
 
DAINCUBE Corp. 
ARM Cortex-A9 Linux system  

 
 
 
 
 
 

FORM 140108F – 2018.01.11 
 

 
 

        
 
 
 
 
 

DTP10-L Software user’s manual 
Form 140108F-171206— January, 2018 
 

DAINCUBE Corp. 
Web: www.daincube.com 
E-mail: sales@daincube.com 
Tel: 82-32-329-9783~4 
Fax: 82-32-329-9785 
 
#401-701, Bucheon TechnoPark 4-Danji,  
655 Pyeongcheon-ro, Wonmi-gu, Bucheon-Si, 
Gyeonggi-Do, Republic of Korea 
 
 
Copyright ©  2005–2018 Daincube 
All rights reserved. 
Printed in the Republic of Korea 

http://www.daincube.com/


 

Preface 
 

Copyright notice 

Copyright ©  2005–2018 Daincube.  All rights reserved.  

Copying of this document, and giving it to others and the use or communication of the Contents thereof, is  

forbidden without express authority. Offenders are liable to the payment of damages.  

All rights are reserved in the event of the grant of a patent or the registration of a utility model or design. 

 

Important information 

This documentation is intended for qualified audience only. The product described herein is not an end user  

product. It was developed and manufactured for further processing by trained personnel.  

 

Disclaimer 

Although this document has been generated with the utmost care no warranty or liability for correctness or  

suitability for any particular purpose is implied. The information in this document is provided “as is” and is  

subject to change without notice. 

 

Trademarks 

All used product names, logos or trademarks are property of their respective owners. 

 

Product support 

DAINCUBE Corp. 

Web: www.daincube.com 

E - MAIL: sales@daincube.com 

 

Safety precautions  

Be sure to observe all of the following safety precautions.  

Strict observance of these warning and caution indications are a MUST for preventing accidents, which 

could result in bodily injury and substantial property damage. Make sure you fully understand all definitions  

of these terms and related symbols given below, before you proceed to the manual. 

 

Safety precautions  

The following symbols may be used in this specification: 

⚠ Warning: 
Warnings indicate conditions that, if not observed, can cause personal injury. 

⚠ Caution : 
Cautions warn the user about how to prevent damage to hardware or loss of data. 

✏ Note: 
Notes call attention to important information that should be observed. 
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1. Introduction 

Thank you very much for purchasing our product.  

Improper usage or mishandling may result in a product not only being unable to deliver full functions but 

also produce unexpected troubles or shorten the product’s life.  

Please read this manual carefully, and operate the product properly by paying attention to its handling. 

When operating the product, always keep this manual at hand and read the relevant items as required. 

 

1.1.  General precautions 

 Be sure to read this Instruction Manual for proper use of this product.  

 Part or all of this Instruction Manual may not be used or reproduced without permission.  

 Please take note that we shall not be liable for any effects resulting from using this Instruction manual.  

 This manual may be modified when necessary because of improvement of the product, modification or  

changes in specifications. 

  Some drawings in this manual are shown as a typical example and may differ from the shipped product. 

 

2. Safety information 

 Before unpacking and installing the product or adding devices on it, carefully read all the manuals that 

came with the package. 

 Avoid using product in extreme dust, humidity and temperature conditions. Do not place the product in 

wet area. 

 Before carrying out assembly and adjustment work or maintenance and inspection work of the machine,  

be sure to disconnect the power cord. Otherwise, electric shock may result. 

 After turning OFF power, wait at least five minutes before servicing the product. Otherwise, residual  

electric charges may result in electric shock. 

 

⚠ Warning 

 Be sure to check grounding before you use the unit. Danger of personal injury due to electric shock! 

 Be sure to use the unit within the voltage range indicated. 

 The operator must have a sufficient educational level and must know details of intended use  

described in the user’s manual. 

 Be sure to check the wiring to the main unit.  

 When the user (customer) extends wiring, malfunction may occur due to faulty wiring. In this case, 

inspect wiring thoroughly and check it for properness before turning on the power. 

 Before operating the unit, be sure to check that there is no danger in or around the operating range. 

 Do not allow water or oil to get on the unit and the power cord. 

 Install the unit in a place which can endure its weight and conditions while running. 

 Take care not to squeeze and thus damage the cable with any object. 



 

 Do not lay the cable over sharp edges to avoid damaging the cable sheath. 

 Check the mounting screws regularly so that they are always firmly tightened. 

 Never touch terminals directly or internal parts of controller. 

 Do not disassemble or modify the product. 

 Before carrying out assembly and adjustment work or maintenance and inspection work of the 

machine, be sure to disconnect the power cord. 

 Connect the power supply after completing the adjustment of all the cables and switches. 

 

⚠ Caution  

 After the shutdown window, turn off the power supply. Otherwise the components could be 

destroyed or undefined signals could occur. 

 To prevent the equipment from falling to the ground. 

 Never lay the device onto unstable surfaces. It could fall to ground and thus be damaged. 

 It is recommended to use the unit in an environment where no electrical noise is present. In noisy  

environments, use a filter fitted. 

 Never lay the device close to heat sources or into direct sunlight. 

 Avoid exposing the device to mechanical vibrations, excessive dust, and humidity or to strong  

magnetic fields.  

 Make sure that no foreign objects or liquids can penetrate into the device. 

 Wipe the power plug with a clean, dry cloth periodically to eliminate dust. 

 Always pay special attention to the robot’s movement in the Teach Mode. 

 

3. Warranty and warranty coverage 

The Teach Pendant you purchased has been delivered upon completion of our strict shipping test. 

 

3.1. Warranty period 

The warranty period is as follows: 

 12 months after our shipment. 

 

3.2. Scope of the warranty 

Where a defective condition occurs during proper use conditions and obviously under the responsibility of 

the manufacturer, within the term above, we shall repair the product without charge.  

However, any items that apply to the following are excluded from the warranty coverage. 

 

 The warranty is not valid if the defect is due to accidental damage, mishandling, misuse, voltage 

fluctuation, high/low voltage or natural disaster.  

 If the product is repaired or tried to repair from unauthorized personal/Repair Shop. 



 

 If the product serial number is tempered. 

 The product is defective due to wear of parts, which can be considered as consumable parts by the  

nature. (such as a cable)  

 Defects resulting from changes over time such as natural color fading of paint. 

 Defects resulting from mishandling or improper use. 

 Defects resulting from an inadequacy or error in maintenance and inspection. 

 Defects resulting from the use of any part other than our genuine parts.  

 Defects resulting from a modification not approved by us or our dealers. 

 

Only a delivered product shall be singly warranted, and no damage induced by the defect of the delivery 

product can be warranted. For repair, transport the product to our factory. 

 

3.3.  Service coverage 

The cost of a delivered product does not include expenses for program creation and engineer dispatching.  

Therefore, the following are charged separately even within the warranty term: 

 

 Maintenance and inspection. 

 Technical guidance and technical training in the operating instructions. 

 Technical guidance and technical training on program-related matters such as program creation. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 



 

4. Features 

DTP10-L is an embedded-based teach pendant with a high-performance Cortex-A9 (ARM 1GHz * 4 core) 

processor. It accommodates the needs of various industrial fields, supports various communication 

methods, and uses Linux OS without royalty. Most Linux development tools and Open sources known to 

engineers make it easier to develop applications. DTP10-L’s device drivers and sample programs are all 

available through customer support. 

4.1. Software specification 

Name Version 
Linux Kernel 3.14.38 

Real-time OS 2.6.4 

EtherCAT 1.5.2 

Qt 5.4.2 

gcc 4.9.2 

 

5. How to build a software development environment 

5.1. Host Requirements 

5.1.1. Ubuntu 14.04 

1. This document describes software development environment in Ubuntu 14.04. 

2. In Ubuntu 14.04 later, development environment was not built. If you want to proceed to a version 

other than Ubuntu 14.04, you may encounter a lot of problems and many additional settings may be 

needed to fix it. There are many versions of the Linux distribution, and we can not support all of them, 

so any version not covered in this manual should be solved on your own. 

 

5.2. Ubuntu settings 

5.2.1. Ubuntu login 

 

You should login Ubuntu 14.04-CG4300 that we provided. Password is “daincube”. 

 



 

5.2.2. Ubuntu terminal 

 

In order to enter the command line in Ubuntu, you need to run Terminal.  

 

5.2.3. Host package installation 

After installing Ubuntu, install the utilities and libraries by typing the following command at the console. These are 

the programs you need to develop. 

You do not need to use Ubuntu 14.04-CG4300. It is already working. 

$sudo apt-get install asciidoc autoconf automake bison build-essential  

$sudo apt-get install ccache chrpath coreutils curl cvs desktop-file-utils 

$sudo apt-get install diffstat docbook-utils dpkg g++ gawk gcc gcc-multilib  

$sudo apt-get install gettext git-core groff help2man ia32-libs intltool  

$sudo apt-get install lib32z1 libc6-dev-i386 libdbus-glib-1-dev libfreetype6-dev  

$sudo apt-get install libgl1-mesa-dev libglu1-mesa-dev libgtk2.0-dev liblzo2-dev  

$sudo apt-get install liborbit2-dev libsdl1.2-dev libtool lzop  

$sudo apt-get install m4 make mercurial ncurses-dev python-pysqlite2  

$sudo apt-get install python-xcbgen rpm scrollkeeper sed socat subversion  

$sudo apt-get install tcl texi2html texinfo uboot-mkimage u-boot-tools  

$sudo apt-get install unzip uuid-dev wget xsltproc xterm zlib1g zlib1g-dev 

 

 

 

 

 



 

5.2.4. Samba server setup (If necessary) 

If Samba (file sharing utility) is installed, development becomes easier. If necessary, install and set up as below.  

$sudo ufw disable 

$sudo apt-get install samba 

$sudo vi /etc/samba/smb.conf 

[/etc/samba/smb.conf] 

[global] 

hosts allow = 192.168. 192.168. 127. 

 

####### Authentication ####### 

guest ok = yes 

guest account = root 

 

[home] 

path = /home 

writeable = yes 

guest ok = yes 

$sudo service samba restart 

$sudo shutdown –r now 

 

5.2.5. ssh server setup (If necessary) 

You can also connect to ssh client. 

$sudo apt-get install openssh-server 

$sudo gedit /etc/ssh/sshd_config 

$sudo /etc/init.d/ssh restart 

 

5.2.6. tftp server setup (If necessary) 

Please install it if necessary. 

$sudo apt-get install tftpd-hpa 

$sudo vim /etc/default/tftpd-hpa 

$sudo service tftpd-hpa restart 

 

5.2.7. nfs server setup (If necessary) 

$sudo apt-get install nfs-common nfs-kernel-server portmap 

$sudo vi /etc/exports 

$sudo /etc/init.d/nfs-kernel-server restart 

$sudo /etc/init.d/portmap restart 

 



 

5.3. Build tool setup 

5.3.1. Toolchain setup 

Install Toolchain that we provided. 

$./poky-glibc-i686-meta-toolchain-qt5-cortexa9hf-vfp-neon-toolchain-1.8.sh 

 

5.3.2. Xenomai setup 

Unzip the Xenomai Real-time library under the /opt/ directory. 

$tar xvfz xenomai-2.6.4.tar.gz /opt/ 

 

5.3.3. Qt creator setup 

Install Qt Creator 3.5.1 

Execute the Qt Creator installation file with the following. 

$./qt-creator-opensource-linux-x86-3.5.1.run 

 

 



 

 

 

 

 



 

 

 

 

 



 

 

 

 

 

 

 

 



 

To cross-compile with QT Creator, you must specify the cross-compiler in qtcreator.sh. 

$vi /opt/qtcreator-3.5.1/bin/qtcreator.sh 

[/opt/qtcreator-3.5.1/bin/qtcreator.sh] 

source /opt/poky/1.8/environment-setup-cortexa9hf-vfp-neon-poky-linux-gnueabi 

#! /bin/sh 

 

Add the following string to /opt/qtcreator-3.5.1/bin/qtcreator.sh. 

Be sure to use before the “#! /bin/sh”. 

source /opt/poky/1.8/environment-setup-cortexa9hf-vfp-neon-poky-linux-gnueabi 

When the modification is complete, run Qt Creator with the command below. 

$/opt/qtcreator-3.5.1/bin/qtcreator.sh &  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

5.4. Qt GUI application project 

5.4.1. Create a Qt GUI application (Helloworld) 

File > New Project… Select to create the project. 

 

 

Select Projects > Application > Qt widgets Application and Choose… button. 

 

 Enter the Project name and path and click Next >. 



 

 

  

 

 

 

 

 

 

 



 

If the “Kits Selection” setting is already set, you can select it and you can select it later. 

 

 

 

 

 

 

 

 



 

 Version Control Tool(SVN, GIT…) can be set. Click Finish. 

 

 

Projects created. 

 

 

 

 

 



 

To make Cross-Compile, type the following. 

target.path is the internal path of the board(CG4300).  

 

 

$vi helloworld.pro 

[helloworld.pro] 

#cg4300 

{ 

INCLUDEPATH += /opt/poky/1.8/sysroots/cortexa9hf-vfp-neon-poky-linux-gnueabi/usr/i

nclude/qt5 

 

DEFINES += __LINUX_ARM_ARCH__ 

 

target.path = /home/daincube 

INSTALLS += target 

} 

Add the following string to helloworld.pro.  

 

 

1 

2. Please insert options as below. 



 

5.4.2. Debugging a Qt GUI application (Helloworld) 

Some settings are required for debugging as shown below. 

 

Set the cross-compiler in Options > Build & Run > Kits. 

 



 

If you specify qmake location in Options > Build & Run > Qt Versions, the version is checked 

automatically. 

 

 

 

 



 

 Options > Build & Run > Debuggers must be set to arm-poky-linux-gnueabi-gdb to enable remote  

debugging of the CG4300. 

 

 Options > Devices information is the network information of the CG4300 product. 

 

 Debugging CG4300 remotely. 



 

 

 

 

[helloworld application executed on CG4300] 

 

 

 

 

 

 



 

5.4.3. Xenomai real-time project 

To use the Xenomai real-time api, you need to specify the path to the Xenomai library and include file in 

the project. This example program (ecat_servo_motion) is not a Qt application. However you can create 

it as a plain C project and manage it with Qt Creator. 

 

Add the following string to the Qt project file (ecat_servo_motion.pro) using the Xenomai api. 

[ecat_servo_motion.pro] 

#cg4300 

{ 

INCLUDEPATH += /opt/xenomai-2.6.4/include 

INCLUDEPATH += /opt/poky/1.8/sysroots/cortexa9hf-vfp-neon-poky-linux-gnueabi/usr/include/qt5 

 

LIBS     += -lpthread -L/opt/xenomai-2.6.4/lib -lxenomai -lnative 

DEFINES += __LINUX_ARM_ARCH__ 

 

target.path = /home/daincube 

INSTALLS += target 

} 

 

2. Please insert options as below. 

 

1 



 

6. EtherCAT Example 

This section describes how to use the example program to control the servo drive and motor and how to 

build it. 

6.1.  DTP10-L and Servo Driver Connection 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Debug(RS-232) 

24V 300mA 

Host PC 

Target 

(DTP10- L) 

Ethernet router 



 

6.2.  EtherCAT Sample application description and usage 

6.2.1.  EtherCAT Master & sample application execution 

After booting by connecting to DTP10-L as in above 6., power on DTP10-L and boot up. Then check the 

following files in “start.master” and “stop.master”. 

 

 [Check to start.master script] 

[root@CG4300-Q7 /]# vi /home/daincube/start.master 

 

/etc/init.d/ethercat start                         -> EtherCAT Master Start 

insmod /lib/modules/3.14.38/ethercat/ec_ddcxen.ko 

                                                   -> Add to EtherCAT Master Module 

export LD_LIBRARY_PATH=/usr/xenomai/lib 

export DISPLAY=:0 

 

/home/daincube/ecat_servo_motion -c 1000 -v l -s 30 -t f -a 3 & 

 

/home/daincube/ecat_servo_gui_qt5 &                -> Execute Qt application 

 

 

 [Check to stop.master script] 

[root@CG4300-Q7 /]# vi /home/daincube /stop.master 

 

/etc/init.d/ethercat stop               -> EtherCAT Master Start 

rmmod ec_ddcxen                         -> Remove to EtherCAT Master Module 

rmmod ec_fec                            -> Remove to Ethernet Module 

 

From the DTP10-L Console terminal, enter the following commands to run the EtherCAT Master and Qt 

sample application. 

[root@CG3300 /]#  

[root@CG3300 /]# /home/daincube /start.master 

Shutting down EtherCAT master 1.5.2 EtherCAT: Master module cleaned up. 

 done 

Starting EtherCAT master 1.5.2 EtherCAT: Master driver 1.5.2 2eff7c993a63 

EtherCAT 0: Registering RTDM device EtherCAT. 

EtherCAT: 1 master waiting for devices. 

IPv6: ADDRCONF(NETDEV_UP): sit0: link is not ready 

ec_fec 2188000.ethernet: Unbalanced pm_runtime_enable! 

… Syncopation … 

 



 

EtherCAT WARNING 0-2: Slave did not sync after 5000 ms. 

EtherCAT 0: Slave states on main device: OP. 

ec-app:  Slave[0] Set SERVO_ON 

ec-app:  Slave[1] Set SERVO_ON 

ec-app:  Slave[2] Set SERVO_ON 

ec-app:  [slv_inx:0] = target_val:1886989899 

ec-app:  [slv_inx:1] = target_val:-990230200 

ec-app:  [slv_inx:2] = target_val:1053377192 

ec-app:  ServoRun .. 

Command :  

 

When this is done, the motor is running and the servo driver can be controlled by entering command at 

the DTP10-L console terminal. 

 

6.2.2.  Terminating the EtherCAT Master & sample application 

When running EtherCAT sample application, enter the following command at the DTP10-L console 

terminal to terminate the sample application and then enter the command again to terminate the 

EtherCAT Master. 

 

Command:  

Command: exit 

EtherCAT Stop 

ec-app:  dec_close_domain_data (0) 

 

 

6.2.3.  EtherCAT sample application argument 

When you run EtherCAT sample application, you need to input and execute arguments for the servo 

driver. 

Ex) ./ecat_servo_motion -c 1000 -a 2 -v l -s 25 -t f 

Option Argument Range Unit Default 

Cycle Time -c 1000 ~ 16000 us 1000 

Servo Axis -a 1 ~ 6 Axis 2 

Servo Vendor -v s: sanyo 

o: omron 

l: ls mecapion 

e: elmo 

- l: ls mecapion 

Run Speed -s 1 ~ 100 - 25 

Run Type -t f: forward 

r: reverse 

- f: foward 



 

t: task 

 

6.2.4.  EtherCAT sample application command 

You can control the servo driver by entering additional commands while running the EtherCAT sample 

application. 

Option Command Operation 

Servo ON on Servo driver status is Servo On status. 

Servo OFF off Servo driver status becomes Servo OFF status. 

Servo Run run Servo driver status becomes Servo Run status and 

motor starts. 

Servo Stop stop Servo driver status becomes Servo Stop status and 

motor starts. 

Exit exit Exit application 

 

6.2.5. EtherCAT sample application build 

Extract the file “DTP10-L_SDK >> Example >> EtherCAT_Example >> 

“ecat_servo_motion_qt_20170322.tar.gz” to the desired location on the host PC. 

 

[How to unzip] 

HOST_PC # mkdir /Example 

HOST_PC # tar xvfz /home/daincube/ecat_servo_motion_qt_20170322.tar.gz 

 

Refer to 5.4.3 and build from Qt. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

6.3.  Qt EtherCAT GUI example 

This section explains how to use the Qt example program and how to build a motor by controlling the 

servo driver with the EtherCAT master of DTP10-L. 

6.3.1. DTP10-L and servo driver connection 

Refer to 6.1 and connect DTP10-L to servo driver. 

 

6.3.2. Running the EtherCAT Master & Qt GUI sample application 

When Qt application is executed, the following screen appears on the DTP10-L screen. 

Set Cycle Timer, Slave Nums, Device vendor, Speed to slave device, 

When you are finished, click “Start” button to start EtherCAT. 

 

 

 

The slave device status is displayed in the EtherCAT state and you can see the state change.  

EtherCAT state changes to Pre-Op mode. Wait until OP mode changes.  

If the slave state is changed to “OP” mode, the slave device is ready. Click the “On” button to activate 

the servo driver.  

When Master state is “OP”, press the “On” button to tern “Servo On”. 

 

 



 

 

 

 

 

Press the “Run” button to turn the motor. 

 

 

 

 

 

 

 

 



 

7. FAQ 

7.1. Default password 

Target board (CG4300) 

ID : root 

PW : daincube  

 

7.2. C: Command not found 

 

Symptom  :   When running Qt Creator, c: Command not found 

Cause    :  The path where the cross-compiler is installed should be recognized. 

Solution :  Execute $ /opt/qtcreator-3.5.1/bin/qtcreator.sh & 

At this time, the path-related settings must be applied in qtcreator.sh.  

 

 

 


